パッケージを特定のバージョンに固定する

この間のia32-libsみたいに、アップグレードされると困るものが出てきたとき、パッケージのバージョンを固定しようという話になる。
apt pinningでもできるのだが、いちいち設定書くのが面倒だな、と思って調べてみたら、wajigなるものがあるようで。
wajigはaptやdpkgのフロントエンドとして振る舞うようだ。
とりあえず、基本的な使い方は以下

wajig [options] [command] [packages|files] …

んで、GUIでも使えるようで、その場合はgjigとたたくとGNOMEなjigが立ち上がる。
コマンドは色々あるんで、wajig commandsをたたくかgjigでながめたほうが早い。

で、とりあえず今回はia32-libs-gtkのバージョンを固定したいので、以下のようにする。

# wajig hold ia32-libs-gtk

解除したいときはunholdすればいい。
たぶんコマンド眺めればなにが何のためのコマンドかわかる。
説明も書いてるし。

でもこれって明らかにDebianとかUbuntu専用コマンドだろうね。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>